Gizmoplex Roku app cannot connect

Just before the new Gamera episode dropped I started receiving an error in the Gizmoplex Roku app. It shows the side menu and a grey screen where the content should be, with an error about being unable to display the content and button to retry. I have since moved house and was hoping it was a temporary glitch, but I’m still getting the error here in my new location. Nothing I have tried so far has fixed it.

Has anyone else experienced this issue? If so, is there a resolution?

1 Like

I also use that app on the Roku, and I also recently moved, but I haven’t experienced that.

My only suggestion, which you’ve probably already tried, is to reboot the thing, because it’s dumb as a stump. More than once I’ve had to actually pull the plug on it, because it’s that dumb, and needs to be taught that you’re the god YOU’RE THE GOD.

3 Likes

Thanks. I have tried a reboot, to no avail, as well as updating the app itself. I suspect I’m going to have to log out and log back in, which I haven’t tried yet because I haven’t gotten around to setting up my PC with all my passwords.

1 Like

I keep passwords like that in my PostItNote/AssortedPaperScrapsDB, which got scrambled during the move. It took me a few tries to stumble across the right one, because my brain also got scrambled.

1 Like

Roku app was working for me as recently as two days ago (Saturday)

1 Like

It could be a corrupted/interrupted update. Have you tried removing the app from Roku and re-installing it?

1 Like

Logging out and back in fixed it. Changed my password in the process as well, though I don’t think that step made any difference. Anyway, I’m in again, and thank you all for the advice!

2 Likes