I have gizmoplex on Roku. I can't watch any s13 episodes. Help?

I know a few episodes are available, I can see them available on my laptop when I go to the gizmoplex website. But on the Roku gizmoplex app, I only see S1-10 episodes to watch, as well as trailers for S13 episodes. No option to view full S13 episodes. What might I be missing or doing wrong?

I’m also a Roku user. Go to “library,” then scroll down until you see “Gizmoplex Member Pass.” Click it and you’ll see the S13 eps along with the livestream replays.

(This assumes you have a Gizmoplex pass.)


You can also search for the individual episodes to buy. The current S13 eps are:

Santo in the Treasure of Dracula
Robot Wars
Beyond Atlantis

My “library” page is completely blank.

Searching finds only the trailers.

You have to scroll down on the library page - further than you would think…

1 Like

@Vader’s right; keep mashing that down button!

My library page is completely blank–a black screen (with the words “book mark content for later by adding them to my list” at the top).

I pushed “down” on my remote fifty times on the library screen, with no result. (And each time the app made the beep sound usually associated with the message “there is nowhere to move to in the direction you just pressed.”)

For good measure I tried pushing right on the remote fifty times, to the same result without the “nowhere to go” beep.

And like I said, search finds only trailers for the new episodes, not the new episodes themselves. (Specifically I searched “Santo.”)

It seems like the app just doesn’t think the new episodes exist.

Stupid question - are you signed into your gizmoplex account on the app?

I believe so but in case I’ve made a mistake in that regard I’ll try signing out and back in.

I logged out and back in, to the same result–I can watch S1-10, I can watch S13 trailers, but not S13 episodes. My library is completely blank, and there is no option anywhere in the app to purchase or rent the new episodes.

Okay, I either figured out a workaround or a very surprising aspect of the gizmoplex.

Apparently if I purchase the episode in Windows on my laptop, I can now see it in my library on the roku.

What I expected was to be able to purchase episodes in the roku app itself. Is that not intended to be possible?

1 Like

They confirmed a while back that you can’t make purchases through the apps because of some tech reason. If you want to purchase an episode you need to do it through the website.


Yeah, that’s a quirk of the Roku/Amazon ecosystem. But the workaround you discovered is correct!