SOLVED: App stuck in download queue—Fire TV

For the past couple of days I haven’t been able to use the app. I get the “We were unable to load this content. Please try again.” message. I’ve tried logging out and logging back in again (it never includes the activation code so I’ve had to type in my email/password which isn’t a big deal really but might be part of the issue so I thought I’d mention it), clearing the cache, uninstalling and reinstalling the app. Nothing so far. I can watch videos on the website but not on my FireTV. I just want to watch “Overdrawn at the Memory Bank” is that too much to ask?!? Seriously, thank you in advance for any help/suggestions you guys have.


So this is only a problem on your FireTV stick?

Try uninstalling and reinstalling the app entirely.

1 Like

I don’t have a stick, I have a FireTV. But, yes, it’s the app I can’t use. I can go to the website and watch anything. I’ve uninstalled the app again but this time I also remembered to delete it from the cloud and ‘bought’ it again from Amazon. I’ve clicked download but now it’s just sitting in queued.

Trying that now. Now it’s stuck in queued and won’t download.

edit: It finished downloading and installing. I got the activation code on the screen and it went through fine. I got the ‘you’re all set to go’ message and then when I clicked on it I immediately got “We were unable to load this content. Please try again.”

1 Like

Here are some steps for that issue that I found (posted by an Amazon tech) in a Fire TV support forum. I’m not familiar with the device/interface, but am sharing in case they’re of help.

  • Go to Settings>> Applications>> Manage installed apps>> Appstore >> Clear cache >> Clear Data .

  • Restart your device.

  • You will have to initiate the download again after restart.

  • If issue persists >> Go to Settings>> My Fire TV>> About >> Update >> Check for updates >> Make sure all latest software are updated.

Link to page:

1 Like

Thanks Michael! I’ve done all of those things so far. Now I’m trying to download the app again after deleting it from my device and from the cloud. It’s stuck in queue mode and… that’s pretty much where I’m at right now. Checked connection speeds and they’re all good. Other apps are working (apart from Disney+ but I know a few people having trouble since they did an update a couple days ago).

1 Like

Well drat. I’m going to update the title of the thread just in case someone else here has been in a similar spot and has some input. I’ll keep digging for info as well, but I’m sure Ivan will figure it out before I do. :grinning:

Only asking because I recently had a very strange download issue with an app: do you have a 2nd option for a WiFi network? If so, try switching to that and see if it makes any difference.

After nearly 2 hours on the phone with Adobe tech support, reinstalling EVERY possible thing I could reinstall, the final piece wouldn’t download until I changed networks. Weirdest thing ever. Once downloaded I went back to my original network and everything worked normally.

I’m old. I’ve got it hooked up through an Ethernet cable. (The wireless connection where I’m at sucks bigly.)


Totally understandable—Just thought I’d suggest it. If you’re hardwired then network connection shouldn’t be the issue.

You might try turning off the TV and unplugging it for a few minutes, then plug back in and turn on. Check your queue and see if it moves then. Good old fashioned reboot solves lots of things.

1 Like

Thanks NotTVsFrank! That was actually one of the first things I tried but I’m not lucky enough for it to have been that easy. I’ve even made sure to check that the FireTV has the latest version available. I’m running out of ideas. Thanks taking the time to comment!

New thing to try:

Hold the play button down along with the center “enter” button. The firestick will power off/on. When mine powered up the stuck app immediately started to install. Hope that works for all.

I tried it yesterday, but I tried it again just now with the same result. It’s been difficult to find anything online about the FireTV smart TV as opposed to the Firestick. I’ve gone into permissions to make sure the app has permission to access whatever it needs and that seems to be okay. I really do want to thank you for everything you’ve suggested so far.


Send an email with the details to and we’ll pass it to the app developers to help resolve?

1 Like

Will do, Ivan, thank you. As a sort of workaround, I’ve pulled up the Gizmoplex on the web browser on the smart TV for now. Thanks again.

1 Like

Thank you for bringing that to our attention.

And welcome to the forums!

1 Like