SOLVED:....are the GP videos down?

I tried logging out and back in, no ad blockers or anything, just getting static on all streaming. I can download some of the earlier stuff without any issue but streaming is RIGHT out…apparently.

1 Like

I’m having the same issue as well.

It seems to be working now. Tried Mordrid at both the VHX site and the Virtual Theater and it worked. (The Virtual Theater was slow to load canisters, but once they were there they worked).

Where were you having the problem and are you still having the issue now?

Looking at the timestamp as being about midnight my time last night, there was a Cloudflare outage, which can take down lots of things. (I noticed it at first because Discord wasn’t connecting.) Cloudflare fixes outage that knocked popular services offline – TechCrunch So if VHX/Gizmoplex uses them, that could explain it.


My partner was telling me over the weekend that there was a solar flare causing disruptions in communications and networks. Perhaps there’s some aftermath happening.

Definitely a flair problem, and we suspect this woman is to blame:



I just tried to watch The Magic Sword and got this:


But I just tried the first KTMA episode and Teenage Caveman and both of those worked for me.

I just tried it on the regular VHX side of the site; and The Magic Sword works fine there.

Have you done a hard refresh on the Gizmoplex side? (That would be holding down Control/Command and F5 or Control/Command + Shift + R or whatever other joy some random browser/OS has decided upon… basically forcing the site to not use the local cache and download the information stuff anew).

1 Like

I’m seeing the same behavior here. So far it seems to be limited to Vault Picks in the virtual theater but I’m still trying various titles. A hard refresh made no difference so it doesn’t appear to be cache-related.

Confirmed, the issue appears to be with the Vault Picks in the virtual theater.

Merlin’s Shop does not load

Being from Another Planet does.

Merlins’ Shop does play at the VHX site

1 Like

I was just able to load and play Sinbad. The Vault Pick version.

Oh, but that was in the Gizmoplex app, not in the beta theater.

Glenn was 50 feet tall!


Having a similar problem with all Season 13 videos.

I am now able to play Vault Picks in the Virtual Theater. Can everyone else who was having this issue confirm that it has been resolved?

If you have trouble at first, please hold down Shift and reload the site twice.

1 Like

I can play Vault Picks and Season 13. Perhaps the long national nightmare is over?


We’ve pushed a new build of the Gizmoplex Virtual Theater (v0.9.20) this evening which seems to have fixed the problem. If you’re still experiencing this issue, please try signing out and back into the Virtual Theater.

If the problem continues after that, please post here with details!


So I am having the issues described above right now. I have run some tests and found that the more recent videos are not playing. This includes all Event Replays, all of the Vault Picks and all of the current season. Episodes from the Netflix era and earlier are playing fine. This is occurring in both Firefox and Chrome. I have done a hard refresh multiple times on these pages to no effect. I did log out and back in, also to little effect, just the “skip animation” button disappearing. This is only happening in the virtual theatre. Watching on the VHX site runs videos just fine.

Since there were issues with the live stream last night due to a hiccup with Vimeo, I suspect that problem has bled over into all of the other season 13 episodes as well. Classic episodes do seem to play in the theater, just not the new stuff.