SOLVED: Email already in use?

Finally got my invitation to the Virtual Theater today. Yay! But having a problem getting in. Boo!

I followed the link and tried creating an account using my one and only email account but I get an error saying my email is already in use. So I tried just signing in and I get the black screen telling me to wait for a verification email. After an hour I still haven’t seen one.

I did try signing in a few weeks ago because I thought every backer was invited already before I found out I needed to wait for an invitation. Could that have screwed something up?


Quite possibly. It sounds like you need to email the helpdesk:


Attempt to sign in and see if you can find a forgot password link. Should email you a link to set a password and try again from there.

1 Like

You may be running afoul of what I did. Before I ever got the invitation email I tried to log in using the link circulating here. I created the account and got the “wait while our bots process you” message, but never was able to log in. Once I did get the invite I discovered that I couldn’t use the email again, and thus ended up in this quandary. The Alternaversal support team had to suss it out.


They helped! Now I too can be trapped and forced to watch bad movies while they monitor my mind! Thanks for the link!


Yay, glad you’re in!