SOLVED: Error message when trying to view an event replay

I am trying to watch the event replay of Dr Mordrid and I am getting an error message that the video could not load. I am not having any other issues watching other episodes or live replays, just Dr Mordrid. I missed the live showing and wanted to catch up. Thanks


A few quick questions: How are you trying to watch the Doctor Mordrid livestream event replay?

Are you trying to watch the event replay via a streaming device app (like on a Roku or Amazon Fire TV), or are you trying to watch this on your computer?

And if you’re trying to watch this on your computer, are you trying to watch the event replay at the VHX site at or in the Screening Bunker at the Gizmoplex Virtual Theater at

(Also, welcome to the forums!)


Computer in the Gizmoplex. I thought maybe it was my connection but I’m able to start other episoeds and even some of the other live events on replay. It is just this episode.

1 Like

When you have a chance, please do a hard refresh on the Gizmoplex site and see if that clears up the issue (hold down Shift while reloading the page twice).

Interesting - I was able to start the event replay on my Android phone in Chrome, but after refreshing I am also getting the same error message. So this is reproducible.

1 Like

I tried clearing my mobile Chrome cache and that didn’t help. After that I logged out of the Beta Gizmoplex and logged back in. I was able to play the event replay after that.

@lightjedi, can you please try logging out and logging back in again to see if that fixes the problem?

I did not refresh, but when I came back in a few days later, I did not get that error message and was able to watch the replay of the live stream with out issues. Not sure if it was on my end or not, but thanks.