SOLVED: Gauntlet rentals

So I’ve been renting Season 12 episodes on the Gizmoplex, but there’s not a rent option for The Day Time Ended. It’s currently the only Season 12 episode that can’t be rented. What’s up with that?


Moved this to the help desk so @ivan’s team will see it.

If you are having similar issues, please don’t for get to vote! Bugs and problems are prioritised based on your input and votes.


(Here’s where I attempt a joke about this being the day time to rent ends, but I won’t. I’ll just mention the idea of the joke, which effectively is the same, but I don’t have to take actual blame for it.)

In seriousness, though, I hope this is resolved. It’s long been a movie I enjoy, and I was very happy when it got the MST3K treatment. You should be able to see it.


Looking at the Android Gizmoplex app, it looks like it’s available for me to rent. @Sitting_Duck, what app or site are you using?

I can see the problem on, it’s only giving the “buy” option.

1 Like

I can’t speak for @Sitting_Duck’s situation, but for myself, I found the same situation over here.

I’m using the regular Gizmoplex VHX site on Firefox on a Windows laptop, and The Day Time Ended isn’t giving me a rental option, while the other Season 12 episodes are giving me rental options

Here’s 1204, The Day Time Ended without the rental option:

And here’s the rest of Season 12 with the rental options:

1 Like

The lack of a rental option for The Day Time Ended is also reflected on the main store screen on the Gizmoplex VHX site:

1 Like

I just tried Google Chrome and Microsoft Edge on my Windows laptop, and the same stuff I detailed in my above posts came up the same way there as well.

1 Like

This has been fixed. Thanks for the heads up!