SOLVED: We are in the process of switching over to a new code redemption system.

On Wednesday I finally got around to trying to get my Gizmoplex access set up. Apparently, this was posted a few hours before I got there.

UPDATE: MARCH 16, 2022

6:30 PM ET - We are in the process of switching over to a new code redemption system. The reward code above WILL NOT WORK until this switch is complete. Please check back in a few hours for an update.

As of now, I still get an error when trying to redeem my code. Should I still be waiting a few hours and trying again, or is there another problem I need to get sorted out?


Check your email for an update with the subject line
New Digital Content for Let’s Make More MST3K & Build THE GIZMOPLEX! on BackerKit

If you hadn’t redeemed your code before the Santo event, there is a link you can click to redeem your pass.


I just got another e-mail from BackerKit for a redemption code. Clicking on it told me I already redeemed it.

I assume this is just a procedural thing for the website version and nothing to do with the virtual version?

1 Like

Got the same email to redeem. I have already redeemed and access the awesome livestream 2 weeks ago. I was really hoping it would be the Gizmoplex Virtual Theater but alas it was not.

1 Like

Got the email too. So I’m guessing if your first pass works ok, you don’t need to redeem the second? The email doesn’t specify, but my “old” pass seems to be working fine.


Mined had:
on it but when I went that was still pending. I’ve already claimed everything else.

1 Like

Welp, apparently minutes after I posted, they fixed the problem. I did get the email, but just refreshing my Backerkit page showed the new link.

I still got the invalid code error when I clicked through, but clicking the “Start Over” button made it work.


FYI, there’s a minor bug from your code redemption e-mail links (at least the webpage that they go to):


Looks like you’re trying to tell people when their code was already redeemed, but the script doesn’t have access to that value, or it’s stored in an unexpected format (hence the “Not A Number” value showing).

No big deal, just something to fix up sometime before launch so you don’t freak out any non-techies.

1 Like

Closed due to age and non-recurrence of issue.