Unable to access theater after email verification

So i got my invite email, followed the instructions, received the email verification, activated it. This was the 12th, but even now days later, and clearing my cache several times, I still get this:

The verification email has expired/been used and I’m not sure what else I’m suppose to do to access the theater beta. Javascript is turned on and specifically allowed for the gizmoplex/theater in my browser settings-and I’ve tried three separate browsers, all show the same thing.

Anyone else run into this or am I just going to have to wait it out?

2 Likes

I’m having the same problem. This is the only page I get when I attempt to log in.
Still waiting on a response from the helpdesk.

1 Like

If you haven’t already, send an email to kickstarter@mst3k.com and Ivan or someone on his team will get back to you as soon as they can.

1 Like

I’m having the same issue.

1 Like

Same problem as well. I wrote the kickstarter desk, but also read the email that said there would be no customer support…so i’m afraid i’m just out of luck then? i even tried other browsers.

I’ve been having this issue ever since I got the welcome email. I wrote the helpdesk about it, and since I received no further answer beyond the automated reply, I wrote back again today.

I believe my issues come from having set up an account before receiving the email, just to see if I had access anyway. I didn’t, of course, but now the system wants me to register, and when I use my email address, it says there is already an account.

As a software developer I am assuming there is a step during the registration process that kicks off a verification script before letting you in. Since I can’t re-register with the same email address, that never gets initiated, and my account stays in pending forever.

@ivan , is there any work going on behind the scenes to rectify this? I know you all are gearing up for the public go-live, and I fear that even then my account will be stuck in Pending Hell.

1 Like

We won’t let you get stuck in purgatory – we’ve just been focused on helping people who are having trouble redeeming their member passes, so we haven’t been able to provide any support for Virtual Theater beta test issues yet. Will do my best to get to this tonight!

5 Likes

Are people still being invited to beta test, or should everyone have received an email? I think I remember it being based on backer number, but my sister already received her invite and I know I backed before she did.

3 Likes

Same issue. Followed the instructions to the letter (even changing my Gizmoplex email to the required email assigned to the theater), verifying my account, and still stuck on the “sign out” page. Wondering if it’s not happy I set up the account on Edge on my Mac (work machine, can’t install Chrome). I tried testing on my personal PC on Chrome, but got the same issue.

Going to send an email to the help center but I know they said they’re not doing support right now for the theater. Hopefully there’s a fix. This page is so dark I can’t see the little shadows in the corner.

They’re still going out. I got mine April 10th about 9 PM Pacific for backer number #12011.

All the messages here about it not working make me really hesitant to try to use it :-/

1 Like

Same issue as the OP and others have posted. I’ll email as instructed and continue enjoying everything at Gizmoplex.com until a resolution can be found. (BTW, got my invite at 10pm on 4/10 as Backer #10728.) Have an MST3K day! :sunglasses:

Same issue as the OP.

1 Like

I’m having the same problem - stuck on the Welcome screen. I haven’t emailed the help desk yet; I guess that is next. By the way, I am backer #11707 and I received my invitation on 4/11/22.

Same here, e-mailed help desk.

Mine has started working now and is connected to my videos from the Gizmoplex Library!

3 Likes

Those of you having problems with the login, can you post screenshots of what you are seeing? It might help @ivan and his people track down the glitch.

2 Likes

Got an email back 32 minutes after sending asking me to try again. Works great now! Big thanks to everyone at #MakeMoreMST3K!

3 Likes

It’s in the very first post. We’re all stuck on that screen.

I just got the email myself and same issue. From what I am seeing, people are able to eventually sign in after some time. Sounds like we just need to be patient and once all the emails are sent out for the invitations they will start focusing on issues people have with redeeming.

I’m also having the same issue, and here’s the requested screenshot. It’s been well over 5 minutes, of course, and following the instructions just brings me back to this page.

I don’t mind waiting, but I did email the helpdesk in case they’re tracking the error.