Gizmoplex User/Passwd not working on Roku App

I had an existing Gizmoplex account and purchased the season pass recently (a birthday present). The Gizmoplex works on my PC, but when I installed the Roku App, my e-mail and password don’t seem to work. I’ve rebooted the Roku, reinstalled the app, reset the password, etc. with no positive results.

Is this just a time thing (it takes a day or two), or some known issue with the Roku.


First off, welcome to the forum!

If your account works on PC, it should work on the Roku as well. Are you 100% sure you entered your username and password correctly? It can be a pain on the Roku. If you have a smartphone, I would recommend you try the Roku app. The Roku app will act as a remote control and also allow you to type with your phone keyboard, entering it into the Roku. If you have a long or complex password, it’s a nice alternative to using the remote.

I have re-entered the password many, many times (with others reading it off a character at a time to me). Uninstalled the Roku App and re-installed and went through it again. Reset the password on the website, and again the new password works on the website, but not on the Roku.

The Roku will offer your Roku account e-mail as a default user-id. It is the same as the e-mail I use for the Gizmoplex account, so I am accepting that. Could it be that mechanism? Different password length/complexity requirements for the two devices?

Again, I’m not talking about the user ID and password here, but the Gizmoplex user id and password. We watched a few episodes last night on the browser, but trying the password on the Roku again just a few minutes ago, no joy.

Any random “close one eye and press the remote with your left pinky” potential solutions will be gladly attempted regardless of how silly. But I’m at a loss to think of anything else to do. I do have another Roku, so I may try it on the other unit. The main Roku is an Ultra, but I haven’t had it be any different than others to date.

It should be the same exact password requirements for both. In both cases you’re logging into the same service.

I suggest you try changing your password to something else and see if you can log in with the new password. If that doesn’t work, you can email and explain the problem. It’s supposed to be a simple email and password combo that works across all the different ways to access the show. If changing the password doesn’t help, I’d send an email for help instead of struggling with it any more.

There is known weirdness with Roku. I’d need to go digging back through posts from when the theater opened, let me see what I can dig up.

Okay after going through old posts, here are a few things to try:

The Roku app and the Gizmoplex are not the same thing. You need to be logged into the app, and then find the Gizmoplex “channel” for lack of a better word, and then use your Gozmoplex credentials to log into the Gizmoplex.

So are you able to log into your Roku app?

Are you able to find the Gizmoplex “channel”?

Are you able to log into the Gizmoplex “channel”?

If you’ve tried all of that, there were several people back in the day mentioning they were having issues directly logging in to Roku or that it was in a perpetual “setting Up” loop. They were able to bypass this by using the link in the activation email.

Have you tried that?

EDIT: Searched through KS updates and found this link: "How do I access my Gizmoplex Pass... with Roku?" - MST3K & Gizmoplex Help Desk

There might be something in there that can help. (I don’t have a Roku to try and troubleshoot this with you)

1 Like

Thanks for all the help! Oddly, the problem seemed to be related to the password I was using. The password works for the browser Gizmoplex, but not the Roku service. The solution was to change the password on the browser Gizmoplex to something different than what I had and then try logging into the Roku App.

Not sure what was up there, but it seems to be working fine now.

Thanks Again