Season 13 blu-ray set - disc 8 won't load

Has anyone else run into a problem getting disc 8 to load in your blu-ray player?

The other discs load fine, it’s just the bonus materials that aren’t working.

I only have the one player to try it on but again, 1 - 7 load up fine.

I even tried coloring the edge with a green marker and still nothing!

I suggest you email support: and let them know.

They will probably need to know what your set up is (type of player, that sort of thing)

I get that from time to time on Shout Factory blu-ray discs in general on my PS4. I have a PS5 now and haven’t tried one yet, but it might be one of those “depends on the device” things.


Played a little bit with my set. Can confirm my disc 8 loads on my PS5.

PS4 is a pretty awful bluray player. I’ve always had issues with it not playing certain discs.

It’s odd how different people have such different experiences with same (or similar) products… I’ve never experienced any issues with my ps4 playing dvd or blu ray discs.

Probably because of all the models Sony made. There’s the original, the slim, the pro and probably half a dozen more. I’ve had more luck with Xbox consoles and dedicated players.


great experience with the support folks, they’re gonna send a replacement disc. we’ll give that a shot and if it still doesn’t work, time to go looking for a new player!


I’ll have to take a gander at the disc when it arrives and I test it on my PS3.

The first disc I popped into my PS4 was disc 8. It played for me with no issues.

Just got mine the 8th blu ray plays good. Watching the funny Q and A with the cast

1 Like

I’ve experienced some weirdness myself with the Blu Ray set and my Panasonic UB-820 4K player.

I put in disc 1 and it started to load but got to the point where the time showed on the player’s display but no further (just before the FBI screen). Pressing Stop at that point will eventually cause it to exit to the stop screen after about 20 seconds (this should be pretty much instant). There’s an old trick with Panasonics that lets you bypass some region-locking on discs where if you stop a disc and press the Top Menu button it jumps ahead to the menu (ironically this doesn’t work with Shout! discs). I tried that and it did start to play the FBI screen. I went through all the discs to test and found 5 and 7 also did this. I put disc 1 back in and it actually loaded fine this time. As a test I also tried it on my PS5 and it loaded OK but when I put it back into the Panasonic it didn’t load again. I stopped it once more and just pressed Play this time and it worked.

In short it’s not a problem, just a minor inconvenience for me but this may be related to the issue above. Might be worth feeding it back to Shout! though so they can investigate if there’s something off about the way these are authored.

1 Like

I can confirm that Shout Factory has added new complications to their Blu-ray copy protection scheme, at least the S13 discs, and this is likely the cause of these weird behaviors. (I don’t have more detail yet, still digging into it.) Blu-ray encryption is more robust than DVD, often utilizing Java and requiring an internet connection to get firmware updates that tell a player how to handle revised protection schemes.

A terrible idea of course, as it threatens to make newer discs unplayable in older devices (or any device the user has wisely never connected to the internet). Disney has traditionally been the worst about this, I’m sad to see Shout Factory climbing on board.


DRM come straight from Satan’s rectum.