Not being able to get inside the virtual theater

So I’ve trying to get inside the virtual theater of the gizmoplex, I got the email on Monday, followed the instructions, got stuck on this screen, wait five minutes, signed out then logged back in, and still on this screen! I even contacted the email for any issues logging, I’m trying to be cool, calm, and patient but I’m slowly getting frustrated.


The Virtual Theater is only open during events.

1 Like

No he’s stuck at the verification screen.

Did you receive the verification email? Mine took two tries.


Oh. Never mind .

1 Like

So I made an account for the theater back in March and got the email to verify it, but the link has expired. All I’m just trying to is just get inside the virtual theater but I am stuck on this stupid verify screen.

1 Like

Am I understanding right? You created an account and tried to get in before you received the invitation email?

If that’s the case, you will need to email so they can work some magic, as that seems to create a glitch in the matrix.


" You created an account and tried to get in before you received the invitation email?" Yes that is correct, if I did that by mistake than I’m screwed.

No, not screwed, just have to have some extra help to get it sorted. :slight_smile: Several other people did the same thing and it was taken care of through the email address I posted.

Drop the team a line and let them know what happened (include the email address you are trying to sub with) and they should get it fixed for you. Though I’m not sure if there is anyone around at the weekend right now.


I sent them an email now also including screenshots with my issue, so fingers crossed I hear back


Screen Shot 2022-04-26 at 7.10.15 PM
UPDATE: I made it in!